using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!EMP|NDB|POI|CWR)[A-Za-z\s]{1,25})$";
string input = @"BLA
EMP
BLABLA
NDB";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}