package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-zA-Z]\d{3}|\d{3}[a-zA-Z\d]|\d[a-zA-Z\d][a-zA-Z\d]\d)$`)
var str = `A123
123A
1234
1A23
12A4
A12A
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}