const regex = /^(?:[a-zA-Z]\d{3}|\d{3}[a-zA-Z\d]|\d[a-zA-Z\d][a-zA-Z\d]\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-zA-Z]\\d{3}|\\d{3}[a-zA-Z\\d]|\\d[a-zA-Z\\d][a-zA-Z\\d]\\d)$', 'gm')
const str = `A123
123A
1234
1A23
12A4
A12A
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}