re = /^(?:[a-zA-Z]\d{3}|\d{3}[a-zA-Z\d]|\d[a-zA-Z\d][a-zA-Z\d]\d)$/m
str = 'A123
123A
1234
1A23
12A4
A12A
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end