using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*if(?:[^)](?!\)\s+[a-z]))*[^)]+\)\s+[a-z]";
string input = @"if ( slots[pass[i]].indexOf(passRight[i])==-1 ) // ahk comment";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}