re = /^\s*if(?:[^)](?!\)\s+[a-z]))*[^)]+\)\s+[a-z]/
str = 'if ( slots[pass[i]].indexOf(passRight[i])==-1 ) // ahk comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end