$re = '/^\s*if(?:[^)](?!\)\s+[a-z]))*[^)]+\)\s+[a-z]/';
$str = 'if ( slots[pass[i]].indexOf(passRight[i])==-1 ) // ahk comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);