#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:.*\n){5})(.*\n?)"
Local $sString = "Question text" & @CRLF & _
"A. Answer Option" & @CRLF & _
"B. Answer Option" & @CRLF & _
"C. Answer Option" & @CRLF & _
"D. Answer Option" & @CRLF & _
"Explanation text" & @CRLF & _
"Question text" & @CRLF & _
"E. Answer Option" & @CRLF & _
"F. Answer Option" & @CRLF & _
"G. Answer Option" & @CRLF & _
"H. Answer Option" & @CRLF & _
"Explanation text" & @CRLF & _
"Question text" & @CRLF & _
"I. Answer Option" & @CRLF & _
"J. Answer Option" & @CRLF & _
"K. Answer Option" & @CRLF & _
"L. Answer Option" & @CRLF & _
"Explanation text" & @CRLF & _
"Question text" & @CRLF & _
"M. Answer Option"
Local $sSubst = "$1Explanation\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)