// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:.*\n){5})(.*\n?)").unwrap();
let string = "Question text
A. Answer Option
B. Answer Option
C. Answer Option
D. Answer Option
Explanation text
Question text
E. Answer Option
F. Answer Option
G. Answer Option
H. Answer Option
Explanation text
Question text
I. Answer Option
J. Answer Option
K. Answer Option
L. Answer Option
Explanation text
Question text
M. Answer Option";
let substitution = "$1Explanation\\n$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}