import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:.*\\n){5})(.*\\n?)";
final String string = "Question text\n"
+ "A. Answer Option\n"
+ "B. Answer Option\n"
+ "C. Answer Option\n"
+ "D. Answer Option\n"
+ "Explanation text\n"
+ "Question text\n"
+ "E. Answer Option\n"
+ "F. Answer Option\n"
+ "G. Answer Option\n"
+ "H. Answer Option\n"
+ "Explanation text\n"
+ "Question text\n"
+ "I. Answer Option\n"
+ "J. Answer Option\n"
+ "K. Answer Option\n"
+ "L. Answer Option\n"
+ "Explanation text\n"
+ "Question text\n"
+ "M. Answer Option";
final String subst = "$1Explanation\\n$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}