using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,2}\s+(\d{1,2}\:\d{1,2}\s+){4}(\d{1,2}\:\d{1,2})$";
string input = @"01 01:00 02:00 03:00 04:00 05:00
02 01:00 02:00 03:00 04:00 05:00
03 01:00 02:00 03:00 04:00 05:00
04 01:00 02:00 03:00 04:00 05:00
05 01:00 02:00 03:00 04:00 05:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}