const regex = /^\d{1,2}\s+(\d{1,2}\:\d{1,2}\s+){4}(\d{1,2}\:\d{1,2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,2}\\s+(\\d{1,2}\\:\\d{1,2}\\s+){4}(\\d{1,2}\\:\\d{1,2})$', 'gm')
const str = `01 01:00 02:00 03:00 04:00 05:00
02 01:00 02:00 03:00 04:00 05:00
03 01:00 02:00 03:00 04:00 05:00
04 01:00 02:00 03:00 04:00 05:00
05 01:00 02:00 03:00 04:00 05:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}