// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,2}\s+(\d{1,2}\:\d{1,2}\s+){4}(\d{1,2}\:\d{1,2})$").unwrap();
let string = "01 01:00 02:00 03:00 04:00 05:00
02 01:00 02:00 03:00 04:00 05:00
03 01:00 02:00 03:00 04:00 05:00
04 01:00 02:00 03:00 04:00 05:00
05 01:00 02:00 03:00 04:00 05:00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}