package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-\w ]+$`)
var str = `server name-123
server
server$name
server-name
server name
12345
$@#
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}