re = /^[-\w ]+$/m
str = 'server name-123
server
server$name
server-name
server name
12345
$@#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end