$re = '/^[-\w ]+$/m';
$str = 'server name-123
server
server$name
server-name
server name
12345
$@#
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);