package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`title\s*=\s*'([^']*)`)
var str = `<img class='left' alt='""' src='182-35622' title='MyImage_147x91.png' uri='182-35622' style='width: 147px; height: 91px;'>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}