re = /title\s*=\s*'([^']*)/
str = '<img class=\'left\' alt=\'""\' src=\'182-35622\' title=\'MyImage_147x91.png\' uri=\'182-35622\' style=\'width: 147px; height: 91px;\'>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end