using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=PERSON:).*?(?=\s*\||\s*$)";
string input = @"EMPLOYER:OverOcean | COMPANY:OverOcean | PERSON:Wade Wilson | PERSON:Peter Parker| PERSON:Otto Octavius";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}