$re = '/(?<=PERSON:).*?(?=\s*\||\s*$)/m';
$str = 'EMPLOYER:OverOcean | COMPANY:OverOcean | PERSON:Wade Wilson | PERSON:Peter Parker| PERSON:Otto Octavius';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);