re = /(?<=PERSON:).*?(?=\s*\||\s*$)/m
str = 'EMPLOYER:OverOcean | COMPANY:OverOcean | PERSON:Wade Wilson | PERSON:Peter Parker| PERSON:Otto Octavius'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end