using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w{2}(?=\s\d{1,5}-\d{1,5})";
string input = @"PO Box 18111 Seattle, WA 98118-0111 United States";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}