re = /\w{2}(?=\s\d{1,5}-\d{1,5})/
str = 'PO Box 18111 Seattle, WA 98118-0111 United States'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end