$re = '/\w{2}(?=\s\d{1,5}-\d{1,5})/';
$str = 'PO Box 18111 Seattle, WA 98118-0111 United States';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);