using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\"")http[^\""]+(?=/)";
string input = @"153.12.123.123 - - [13/Nov/2014:15:06:43 -0700] ""GET /icons/AHPS/0.06.png HTTP/1.1"" 123 1234 ""http://198.123.123.123/index.html"" ""Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/1234567 Firefox/33.0""
153.12.123.123 - - [13/Nov/2014:15:06:43 -0700] ""GET /icons/AHPS/0.06.png HTTP/1.1"" 123 1234 ""http://abc.weatherabc.org/?Center=38.123456789"" ""Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/1234556 Firefox/33.0""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}