import re
regex = re.compile(r"(?<=\")http[^\"]+(?=/)", flags=re.MULTILINE)
test_str = ("153.12.123.123 - - [13/Nov/2014:15:06:43 -0700] \"GET /icons/AHPS/0.06.png HTTP/1.1\" 123 1234 \"http://198.123.123.123/index.html\" \"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/1234567 Firefox/33.0\"\n\n"
"153.12.123.123 - - [13/Nov/2014:15:06:43 -0700] \"GET /icons/AHPS/0.06.png HTTP/1.1\" 123 1234 \"http://abc.weatherabc.org/?Center=38.123456789\" \"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/1234556 Firefox/33.0\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")