import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\")http[^\\\"]+(?=/)";
final String string = "153.12.123.123 - - [13/Nov/2014:15:06:43 -0700] \"GET /icons/AHPS/0.06.png HTTP/1.1\" 123 1234 \"http://198.123.123.123/index.html\" \"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/1234567 Firefox/33.0\"\n\n"
+ "153.12.123.123 - - [13/Nov/2014:15:06:43 -0700] \"GET /icons/AHPS/0.06.png HTTP/1.1\" 123 1234 \"http://abc.weatherabc.org/?Center=38.123456789\" \"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/1234556 Firefox/33.0\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}