# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![^,])([^,]+)(?:,\1)+(?![^,])/$1/gm;t' <<< "abc,def,fgh,fgh,xna,fgh,xyz,xyz,xyz,tr,tr,xna"