import Foundation
let pattern = #"(?<![^,])([^,]+)(?:,\1)+(?![^,])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"abc,def,fgh,fgh,xna,fgh,xyz,xyz,xyz,tr,tr,xna"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)