use strict;
my $str = 'abc,def,fgh,fgh,xna,fgh,xyz,xyz,xyz,tr,tr,xna';
my $regex = qr/(?<![^,])([^,]+)(?:,\1)+(?![^,])/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";