#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[\[[(table|pre|text) ]*[\n ].*)({.*})"
Local $sString = "[[table" & @CRLF & _
" {json here: "asdas"}" & @CRLF & _
"]]" & @CRLF & _
"[[pre " & @CRLF & _
" {json here: "asdasx"}" & @CRLF & _
"]]" & @CRLF & _
"[[text {json here: "red"} ]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")