re = /(\[\[[(table|pre|text) ]*[\n ].*)({.*})/
str = '[[table
{json here: "asdas"}
]]
[[pre
{json here: "asdasx"}
]]
[[text {json here: "red"} ]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end