using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^[]*?{.+?}.*?\]";
string input = @" [if you have {a-home} or not] [ or {a-home} ] [ AND {a-home} or not][or yes, you do have]
[h][[e{ll}o]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}