$re = '/\[[^[]*?{.+?}.*?\]/m';
$str = ' [if you have {a-home} or not] [ or {a-home} ] [ AND {a-home} or not][or yes, you do have]
[h][[e{ll}o]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);