package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^[]*?{.+?}.*?\]`)
var str = ` [if you have {a-home} or not] [ or {a-home} ] [ AND {a-home} or not][or yes, you do have]
[h][[e{ll}o]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}