package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\b(T\s|void\s)(\w+<T>)\(.*\);|(\w+[<?\w+>?]*\s)(\w+)\b((\s{[get;\|private get;|set;]+)|\(.*\));)`)
var str = `void Something();
int SomethingElse(Parameter parameter);
List<Something> SomethingVeryElse(One one, Two two);
T Get<T>(params object[] args);
IEnumerable<Plugin> Plugins { get; }
void Set<T>(Func<T> constructor, params object[] args);
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}