use strict;
my $str = 'void Something();
int SomethingElse(Parameter parameter);
List<Something> SomethingVeryElse(One one, Two two);
T Get<T>(params object[] args);
IEnumerable<Plugin> Plugins { get; }
void Set<T>(Func<T> constructor, params object[] args);
';
my $regex = qr/(?:\b(T\s|void\s)(\w+<T>)\(.*\);|(\w+[<?\w+>?]*\s)(\w+)\b((\s{[get;\|private get;|set;]+)|\(.*\));)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}