const regex = /(?:\b(T\s|void\s)(\w+<T>)\(.*\);|(\w+[<?\w+>?]*\s)(\w+)\b((\s{[get;\|private get;|set;]+)|\(.*\));)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b(T\\s|void\\s)(\\w+<T>)\\(.*\\);|(\\w+[<?\\w+>?]*\\s)(\\w+)\\b((\\s{[get;\\|private get;|set;]+)|\\(.*\\));)', 'g')
const str = `void Something();
int SomethingElse(Parameter parameter);
List<Something> SomethingVeryElse(One one, Two two);
T Get<T>(params object[] args);
IEnumerable<Plugin> Plugins { get; }
void Set<T>(Func<T> constructor, params object[] args);
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}