#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/([a-z\.]{4})?([0-9]+.hs-sites|wthubspot|hubspot).com[\/]?"
Local $sString = "https://hubspot.com" & @CRLF & _
"https://www.hubspot.com/" & @CRLF & _
"https://wthubspot.com/" & @CRLF & _
"https://123456.hs-sites.com/" & @CRLF & _
"https://google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")