import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/([a-z\\.]{4})?([0-9]+.hs-sites|wthubspot|hubspot).com[\\/]?";
final String string = "https://hubspot.com\n"
+ "https://www.hubspot.com/\n"
+ "https://wthubspot.com/\n"
+ "https://123456.hs-sites.com/\n"
+ "https://google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}