#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/(?:w{1,3}\.)?[^\s.]*(?:\.[a-z]+)+(?::\d+)?(?![^<]*(?:<\/\w+>|\/?>))"
Local $sString = "This is my text to be parsed which contains url " & @CRLF & _
"http://someurl.com <a href="http://thisshouldnotbetampered.com">" & @CRLF & _
"some text and a url http://someotherurl.com test 1q2w </a> <img src="http://someasseturl.com/abc.jpeg"/>" & @CRLF & _
"" & @CRLF & _
"Hello http://someurl.com</a> <!-- fail -->" & @CRLF & _
"<img src="http://someurl.com/image.jpg>" & @CRLF & _
"http://someurl.localhost.com" & @CRLF & _
"<div>Regex is awesome</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<a href='https://help.mojohelpdesk.com/mytickets/show/26737327'>https://help.mojohelpdesk.com/mytickets/show/26737327</a>" & @CRLF & _
"" & @CRLF & _
"<a href="https://help.mojohelpdesk.com/mytickets/show/26737327">https://help.mojohelpdesk.com/mytickets/show/26737327</a>" & @CRLF & _
"" & @CRLF & _
"https://google.com" & @CRLF & _
"" & @CRLF & _
"https://www.mojo.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://localhost:3000" & @CRLF & _
"" & @CRLF & _
"http://site.quelqu" & @CRLF & _
"" & @CRLF & _
"http://localhost.com:3000" & @CRLF & _
"" & @CRLF & _
"www.google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")