use strict;
my $str = 'This is my text to be parsed which contains url
http://someurl.com <a href="http://thisshouldnotbetampered.com">
some text and a url http://someotherurl.com test 1q2w </a> <img src="http://someasseturl.com/abc.jpeg"/>
Hello http://someurl.com</a> <!-- fail -->
<img src="http://someurl.com/image.jpg>
http://someurl.localhost.com
<div>Regex is awesome</div>
<a href=\'https://help.mojohelpdesk.com/mytickets/show/26737327\'>https://help.mojohelpdesk.com/mytickets/show/26737327</a>
<a href="https://help.mojohelpdesk.com/mytickets/show/26737327">https://help.mojohelpdesk.com/mytickets/show/26737327</a>
https://google.com
https://www.mojo.com
http://localhost:3000
http://site.quelqu
http://localhost.com:3000
www.google.com';
my $regex = qr/https?:\/\/(?:w{1,3}\.)?[^\s.]*(?:\.[a-z]+)+(?::\d+)?(?![^<]*(?:<\/\w+>|\/?>))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}