using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(?:w{1,3}\.)?[^\s.]*(?:\.[a-z]+)+(?::\d+)?(?![^<]*(?:<\/\w+>|\/?>))";
string input = @"This is my text to be parsed which contains url
http://someurl.com <a href=""http://thisshouldnotbetampered.com"">
some text and a url http://someotherurl.com test 1q2w </a> <img src=""http://someasseturl.com/abc.jpeg""/>
Hello http://someurl.com</a> <!-- fail -->
<img src=""http://someurl.com/image.jpg>
http://someurl.localhost.com
<div>Regex is awesome</div>
<a href='https://help.mojohelpdesk.com/mytickets/show/26737327'>https://help.mojohelpdesk.com/mytickets/show/26737327</a>
<a href=""https://help.mojohelpdesk.com/mytickets/show/26737327"">https://help.mojohelpdesk.com/mytickets/show/26737327</a>
https://google.com
https://www.mojo.com
http://localhost:3000
http://site.quelqu
http://localhost.com:3000
www.google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}