package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<!--BEGIN DELIMITER\((?<expr>(\w+))\)-->(?<content>([\s\S]*?))<!--END DELIMITER\((\k<expr>.*)\)-->`)
var str = ` <!--BEGIN DELIMITER(A)-->
sample text
<!--BEGIN DELIMITER(B)-->
another sample text
<!--END DELIMITER(B)-->
<!--END DELIMITER(A)-->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}