// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<!--BEGIN DELIMITER\((?<expr>(\w+))\)-->(?<content>([\s\S]*?))<!--END DELIMITER\((\k<expr>.*)\)-->").unwrap();
let string = " <!--BEGIN DELIMITER(A)-->
sample text
<!--BEGIN DELIMITER(B)-->
another sample text
<!--END DELIMITER(B)-->
<!--END DELIMITER(A)-->";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}