const regex = new RegExp('(?<=http://link\\.com/youtube)(/[^/]+){2}', 'mg')
const str = `http://link.com/youtube/channel/UCanMSlq9In5E1jLt-pObIAw/otherchans/subscriber/featured`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}