$re = '~(?<=http://link\.com/youtube)(/[^/]+){2}~m';
$str = 'http://link.com/youtube/channel/UCanMSlq9In5E1jLt-pObIAw/otherchans/subscriber/featured';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);