re = /(?<=http:\/\/link\.com\/youtube)(\/[^\/]+){2}/m
str = 'http://link.com/youtube/channel/UCanMSlq9In5E1jLt-pObIAw/otherchans/subscriber/featured'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end