import re
regex = re.compile(r"<img\s+src.+^(?!alt).+", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<img src=\"smiley.gif\" alt=\"Smiley face\" height=\"42\" width=\"42\">\n"
"<img src=\"smiley2.gif\" height=\"42\" width=\"42\">\n"
"<img src=\"smiley3.gif\" alt=\"Smiley face Three\" height=\"42\" width=\"42\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")