import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9][0-9]*[eE][1-9][0-9]*|(([1-9][0-9]*\\.)|(\\.[0-9]+))([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?)";
final String string = "Matches\n"
+ "3.\n"
+ "3.3\n"
+ "3.3e2\n"
+ "3.3e-1\n"
+ ".1e1\n"
+ "1.11e12\n"
+ "1.3e-1\n"
+ ".1e1\n"
+ ".2e-14\n"
+ "5E6\n\n"
+ "No match\n"
+ "3\n"
+ "E9\n"
+ ".e3\n"
+ "7E\n\n"
+ "# Bla bla Saker\n"
+ "Exponent:\n"
+ "[eE][\\-\\+]?[1-9][0-9]*\n\n"
+ "Siffra:\n"
+ "[1-9][0-9]*\n\n"
+ "# Förklaring\n"
+ "Stora parantesen\n"
+ " Alt1:\n"
+ " Siffra sen E utan punkt (slutar)\n"
+ " [1-9][0-9]*[eE][1-9][0-9]*\n"
+ " Alt2:\n"
+ " (([1-9][0-9]*\\.)|(\\.[0-9]+))([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?\n"
+ " vänsta sidan innan ([0-9]*)?\n"
+ " parantes (([1-9][0-9]*\\.)|(\\.[0-9]+))\n"
+ " Alt1: ([1-9][0-9]*\\.)\n"
+ " Non Zero leading- siffra sen punkt\n"
+ " Alt2: (\\.[0-9]+)\n"
+ " Punkt sen (måste) siffra\n"
+ " Högra sidan ([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?\n"
+ " ([0-9]*)?\n"
+ " kanske siffra\n"
+ " ([eE][\\-\\+]?[1-9][0-9]*)?\n"
+ " kanske exponent \n"
+ " \n"
+ " \n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}